Reply to this topicStart new topic
> Trade Complete, From Mesa To Peavey
Marc_Maiden
post Apr 13 2009, 02:36 AM
Post #1


GMC:er
*

Group: Members
Posts: 1.164
Joined: 23-October 08
From: Fremont, CA
Member No.: 6.124



hey guys,

so earlier today i made the trade,


my mesa mark I reissue for a Peavey triple XXX 1x12 with a custom built 2x12 (with 2 random celestion speakers) and $200 of delicious cash.


its originally 60 watts, but it has a built in attenuator that he had modded into the amp.

he also traded the electro harmonix 6l6s for JJ el34s, but i think im going to switch him back (he was nice enough to include all the tubes he ever used or had for the amp) since im more of a 6l6 guy


anyways,

if you remember my last story, i was looking for something smaller (obviously this isnt it) but it does have the built in attenuator, a footswitch with 3 individual channels, and EXTREMELY sensitive 3 band eq for each channel as well.

this amp is easily more versatile in the sense that it can use a footswitch for 3 channels and each channel has its own EQ. I got used to playing at low gains with the Mesa mark I, and that i liked...i found the peavey to be very similar to a mesa triple rect that i have been demoing in a shop for a while...the only difference is that the peavey isnt heavy on the bass as is the mesa, although i do find myself still keeping the bass and mids down....

overall, im very pleased with the trade, i will miss the mesa just because it is a mesa, and every mesa is special in its own way....however, this is a great product as well, and for the deal i got, i am very happy...i will be writing and recording a video review for you all when i get the chance later this week.


thats it for now, time to spend days trying to dial in my sound hahaa


--------------------
- Marc
Current Set up:
Atomic Reactor 2x12 Cab/power amp with a Digitech rp1000 as a preamp
Schecter c1 plus electric guitar

Go to the top of the page
 
+Quote Post
Marc_Maiden
post Apr 13 2009, 03:03 AM
Post #2


GMC:er
*

Group: Members
Posts: 1.164
Joined: 23-October 08
From: Fremont, CA
Member No.: 6.124



EDIT:


if you guys recall, i had a problem with my effects loop in my mesa...for a while i thought it was my effects that were bad, turns out, it was the mesas loop that was screwing something up!


i plugged my effects into the loop of the peavey, and it did not change the sound one bit! and they work beautifully!! one thing i also like is the fact that there is a separate control for the both the send and return levels


--------------------
- Marc
Current Set up:
Atomic Reactor 2x12 Cab/power amp with a Digitech rp1000 as a preamp
Schecter c1 plus electric guitar

Go to the top of the page
 
+Quote Post
sted
post Apr 13 2009, 10:03 AM
Post #3


Learning Rock Star
*

Group: Members
Posts: 1.758
Joined: 13-April 08
From: Merseyside, UK
Member No.: 4.882



Gratz mate, glad youre happy and the agonizing is over!! Looking forward to some clips!
Go to the top of the page
 
+Quote Post
berko
post Apr 13 2009, 10:13 AM
Post #4


GMC:er
*

Group: Members
Posts: 1.771
Joined: 2-April 08
From: Budapest, Hungary
Member No.: 4.782



QUOTE (sted @ Apr 13 2009, 10:03 AM) *
Gratz mate, glad youre happy and the agonizing is over!! Looking forward to some clips!


Me too!

It seems weird that a mesa built-in loop can mess things up so easily - I wouldn't have thought that. I only tried my uncle's friend mark iv and that was a great tone monster but i have no experience with the mark i.

Anyway, great to hear you made such a great deal! smile.gif


--------------------
High speed, low drag


Check out my YouTube channel
HERE!


Here you can find my
MYSPACE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 


RSS Lo-Fi Version Time is now: 20th October 2017 - 01:00 AM