Reply to this topicStart new topic
> Midi Woes
JVM
post Apr 29 2009, 08:36 PM
Post #1


Learning Roadie
*

Group: Members
Posts: 2.878
Joined: 2-June 07
From: Raleigh-Durham, NC
Member No.: 1.984



I bought a Korg Nanokey the other day, and I just got it. I hooked it up to the computer (via usb) and downloaded the M1 synthesizer software that comes with it. It works great if I load up the m1 software independently, but I have no idea how to use this thing in Reaper. I can load it in as a virtual instrument, but even then the software doesn't respond to the hardware, but even if I use the on screen key roll, when recording I get a faint buzzing sound. unsure.gif


--------------------
Gear: Fender American Deluxe Stratocaster, Gibson '67 RI Flying V, Mesa Boogie F-30 112 combo, crazy pedals.
Go to the top of the page
 
+Quote Post
Ivan Milenkovic
post Apr 29 2009, 10:01 PM
Post #2


Instructor
Group Icon

Group: GMC Instructor
Posts: 25.396
Joined: 20-November 07
From: Belgrade, Serbia
Member No.: 3.341



Does the M1 works as a VST instrument (by manufacturers specs)?


--------------------
- Ivan's Video Chat Lesson Notes HERE
- Check out my GMC Profile and Lessons
- (Please subscribe to my) YouTube Official Channel
- Let's be connected through ! Facebook! :)
Go to the top of the page
 
+Quote Post
JVM
post Apr 29 2009, 11:07 PM
Post #3


Learning Roadie
*

Group: Members
Posts: 2.878
Joined: 2-June 07
From: Raleigh-Durham, NC
Member No.: 1.984



I believe so. Here are the specs.

[edit] you have to click on the 'specifications' button from that link.

This post has been edited by JVM: Apr 29 2009, 11:08 PM


--------------------
Gear: Fender American Deluxe Stratocaster, Gibson '67 RI Flying V, Mesa Boogie F-30 112 combo, crazy pedals.
Go to the top of the page
 
+Quote Post
Ivan Milenkovic
post Apr 30 2009, 12:58 PM
Post #4


Instructor
Group Icon

Group: GMC Instructor
Posts: 25.396
Joined: 20-November 07
From: Belgrade, Serbia
Member No.: 3.341



OK, what sound card do you use?


--------------------
- Ivan's Video Chat Lesson Notes HERE
- Check out my GMC Profile and Lessons
- (Please subscribe to my) YouTube Official Channel
- Let's be connected through ! Facebook! :)
Go to the top of the page
 
+Quote Post
JVM
post Apr 30 2009, 01:20 PM
Post #5


Learning Roadie
*

Group: Members
Posts: 2.878
Joined: 2-June 07
From: Raleigh-Durham, NC
Member No.: 1.984



I'm not sure actually, some integrated sound card on the laptop.


--------------------
Gear: Fender American Deluxe Stratocaster, Gibson '67 RI Flying V, Mesa Boogie F-30 112 combo, crazy pedals.
Go to the top of the page
 
+Quote Post
Gilmore
post Apr 30 2009, 01:27 PM
Post #6


GMC:er
*

Group: Members
Posts: 342
Joined: 2-October 07
From: Reykjavik, Iceland
Member No.: 2.932



I also have a midi keyboard shipping, and was thinking the same thing. I would think it should work the same way as Guitar Rig or PODFarm for guitars. Mabye you need to check audio settings in you DAW and choose appropriate driver, mabye a driver that installed with the keyboard??



--------------------
Electric Guitars: Gibson SG 61´ Reissue, Gibson Les Paul Classic, Fender Standard American Stratocaster (2008 OW RW) , Fender Standard American Stratocaster (2003 2TSB MPL), Ibanez Prestige RG2570E, Warmoth Telecaster (BlueBurst), Warmoth Custom (CherryBurst).
Accoustic Guitars: Ovation Custom Legend, Ovation Legend (12 string), Martin 000-15M.
Classical Guitars: Jose Ramirez 125 Ano (Cedar), Manuel Rodriguez Model D (Spruce).
Bass: Ibanez SRX500.
Keyboard: M-Audio Keystation 88es.
Recording interface: Focusrite Saffire Pro 24 DPS.
Go to the top of the page
 
+Quote Post
JVM
post Apr 30 2009, 01:32 PM
Post #7


Learning Roadie
*

Group: Members
Posts: 2.878
Joined: 2-June 07
From: Raleigh-Durham, NC
Member No.: 1.984



Possibly, you know, it's kind of funny you mention that because I remember the hassle I had getting my toneport to work too tongue.gif It's not a VST though. I'll look into it a little, but I'm afraid to mess with too many settings less I do something stupid tongue.gif


--------------------
Gear: Fender American Deluxe Stratocaster, Gibson '67 RI Flying V, Mesa Boogie F-30 112 combo, crazy pedals.
Go to the top of the page
 
+Quote Post
Ivan Milenkovic
post Apr 30 2009, 01:44 PM
Post #8


Instructor
Group Icon

Group: GMC Instructor
Posts: 25.396
Joined: 20-November 07
From: Belgrade, Serbia
Member No.: 3.341



Hmm, it should work then, that's strange bro. Try reinstalling the M1 and see if it works then, possibly something is wrong with the VST dll file.


--------------------
- Ivan's Video Chat Lesson Notes HERE
- Check out my GMC Profile and Lessons
- (Please subscribe to my) YouTube Official Channel
- Let's be connected through ! Facebook! :)
Go to the top of the page
 
+Quote Post
JVM
post Apr 30 2009, 01:47 PM
Post #9


Learning Roadie
*

Group: Members
Posts: 2.878
Joined: 2-June 07
From: Raleigh-Durham, NC
Member No.: 1.984



Get back to you all after school. Thanks for the input guys smile.gif


--------------------
Gear: Fender American Deluxe Stratocaster, Gibson '67 RI Flying V, Mesa Boogie F-30 112 combo, crazy pedals.
Go to the top of the page
 
+Quote Post
Saoirse O'Shea
post Apr 30 2009, 05:20 PM
Post #10


Moderator - low level high stakes
Group Icon

Group: GMC Senior
Posts: 6.173
Joined: 27-June 07
From: Espania - Cadiz province
Member No.: 2.194



A few suggestions to try JVM in order:

First, finding the M1. As you manually moved the VST it's possible that Reaper can't find it as the path for Reaper is broken. In this instance you just need to pioint Reaper at the the correct location.:

i) Options/Preferences/Plug-ins/VST. In the path setting click 'add' and manually browse to where you've put the VST'd dll and add it.

Second, the M1 interfacing with Reaper

i) make sure that you have set your midi i/o in reaper up ok (options/Preferences/Audio/Midi devices). The nano needs to be identified as midi in to get it to control anything. If you want to edit it via software you also have to identify it as a midi out here. This may be the main issue you have - the midi i/o not being set correctly. Now try it.

ii) if the nano has cc check its status. Wrong status and you won't be sending note on/off but some other controller info or nothing at all.

Hope fully the above should have done the trick so if all is ok ignore the rest smile.gif .

If not...

Third, Midi/USB issue:

i) try the M1 as a vst in Reaper using a virtual keyboard. If it triggers ok with that then the issue is with the nano/reaper.

ii) try the same but linking the nano via midi rather than USB (if you can). This is to check the midi send is ok - it should be - usually the issue is actually with the USB rather than the midi so. Don't worry if you can't do this bit - it's just a double check.

iii) check the nano's midi and USB drivers at this point. If necessary go to Korg and see if there are any updated ones.

iv) try uninstalling and reinstalling via different USB port that is mounted on your mobo. If you have a choice between mains power and bus power for the nano install with mains power.

Fourth, check Reaper's set up for controllers - never used a nano so don't know whether or not it runs as a control surface or not. Just in case it does...

i) Options/Preferences/Control Surfaces/Add. You may have to look in the nano manual to see what surface the nano needs to be set up as if it doesn't appear here.


--------------------
Get your music professionally mastered by anl AES registered Mastering Engineer. Contact me for Audio Mastering Services and Advice and visit our website www.miromastering.com

Be friends on facebook with us here.

We use professional, mastering grade hardware in our mastering studo. Our hardware includes:
Cranesong Avocet II Monitor Controller, Dangerous Music Liasion Insert Hardware Router, ATC SCM Pro Monitors, Lavry Black DA11, Prism Orpheus ADC/DAC, Gyratec Gyraf XIV Parallel Passive Mastering EQ, Great River MAQ 2NV Mastering EQ, Kush Clariphonic Parallel EQ Shelf, Maselec MLA-2 Mastering Compressor, API 2500 Mastering Compressor, Eventide Eclipse Reverb/Echo.
Go to the top of the page
 
+Quote Post
Andrew Cockburn
post Apr 30 2009, 05:26 PM
Post #11


Moderation Policy Director
Group Icon

Group: GMC Instructor
Posts: 10.459
Joined: 6-February 07
From: CT, USA
Member No.: 1.167



Also:

If the midid keyboard is hooked up right and sending, you need to create a chanel in reaper, drop the VST in as an effect, arm the chanel for recording, select the midi input as what it is recording, and also enable monitoring(the speaker icon) - only then will you be able to use the midi keyboard to actually play the VST in real time. When you have the midi input selected, you will see a kind of red bar thingy that signals it is recieving midi data when you hit the keys - sorry I can;t be more exact I am away from the PC atm.





--------------------
Check out my Instructor profile
Live long and prosper ...

My Stuff:

Electric Guitars : Ibanez Jem7v, Line6 Variax 700, Fender Plus Strat with 57/62 Pickups, Line6 Variax 705 Bass
Acoustic Guitars : Taylor 816ce, Martin D-15, Line6 Variax Acoustic 300 Nylon
Effects : Line6 Helix, Keeley Modded Boss DS1, Keeley Modded Boss BD2, Keeley 4 knob compressor, Keeley OxBlood
Amps : Epiphone Valve Jnr & Head, Cockburn A.C.1, Cockburn A.C.2, Blackstar Club 50 Head & 4x12 Cab
Go to the top of the page
 
+Quote Post
JVM
post May 1 2009, 12:34 AM
Post #12


Learning Roadie
*

Group: Members
Posts: 2.878
Joined: 2-June 07
From: Raleigh-Durham, NC
Member No.: 1.984



Woo, Andrew, I wasn't exactly sure what you were on about but I played with some things based on your suggestions and I got it working smile.gif Cool. Thanks everyone.

Now if I could direct everyone to this thread, I could still use a hand getting ezdrummer working again.

This post has been edited by JVM: May 1 2009, 12:36 AM


--------------------
Gear: Fender American Deluxe Stratocaster, Gibson '67 RI Flying V, Mesa Boogie F-30 112 combo, crazy pedals.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 


RSS Lo-Fi Version Time is now: 22nd October 2017 - 09:56 PM