Reply to this topicStart new topic
> Overcoming Latency With A Midi Controller.
Ctodd
post Jul 25 2009, 01:42 AM
Post #1


GMC:er
*

Group: Members
Posts: 493
Joined: 15-October 07
From: Pennsylvania
Member No.: 3.051



Hey gang,

So I'm trying to play some midi stuff with this new keyboard I got, and as of right now It's pretty much unlpayable because of some latency issues. I'm not sure how to overcome this...

I'm using Reaper, and the controller is a Novation X-Station.

not sure if there is any other info I can give. I am able to process my guitar through gearbox software, and record in Reaper just fine, no latency (that I can hear). So I'm not sure why this is a problem

any tips/tricks?

thanks!

-Chris

This post has been edited by Ctodd: Jul 25 2009, 01:43 AM


--------------------
QUOTE (Emir Hot @ Feb 5 2009, 03:41 AM) *
When you hear something that you really like, take guitar and kill the beast.
Go to the top of the page
 
+Quote Post
UncleSkillet
post Jul 25 2009, 01:52 AM
Post #2


Learning Tone Seeker
*

Group: Members
Posts: 1.525
Joined: 21-January 08
From: Cincinnati, Ohio
Member No.: 3.915



I don't have a MIDI device so I'm not sure what kind of help I can give. However I do have a thought! Make sure Reaper (in the preferences is using the correct driver.) Like when you set up your guitar to use the ASIO driver.

Maybe it will help


--------------------
"Think of a guitar solo as a paragraph. You need a clear beginning, a middle, and an end. Look at musical phrases like sentences, and make sure you break them up using punctuation—or space. You pause naturally when conversing, right? If you don't, you'll bore the listener. The same thing will happen with your audience if your solo is one dimensional. You'll wear them out and lose their attention." —Tom Principato
Go to the top of the page
 
+Quote Post
Ctodd
post Jul 25 2009, 02:11 AM
Post #3


GMC:er
*

Group: Members
Posts: 493
Joined: 15-October 07
From: Pennsylvania
Member No.: 3.051



QUOTE (UncleSkillet @ Jul 24 2009, 08:52 PM) *
I don't have a MIDI device so I'm not sure what kind of help I can give. However I do have a thought! Make sure Reaper (in the preferences is using the correct driver.) Like when you set up your guitar to use the ASIO driver.

Maybe it will help


hmmm I don't know what ASIO is, all I know is that it stands for audio sound input output, or something like that. But your comment made me go into my audio device settings and look for the word "ASIO"

and (I dont really know what these terms are)

my "audio system" was set to "waveout" but ASIO was an option, so i selected that, and different options came up,

I saw something about "thread priority" so I though it might be a good idea to set that to "highest" (later I changed it to "timing critical") and I also checked off a box that read "pre-zero output buffers ... (higher CPU usage)" so I checked that off too thinking it would help... and it did

no (noticeable) latency now!

but would you mind explaining any of the above?? laugh.gif

All I know how to do is tinker with things that look like they might help... I have no idea what I was doing laugh.gif

-Chris


--------------------
QUOTE (Emir Hot @ Feb 5 2009, 03:41 AM) *
When you hear something that you really like, take guitar and kill the beast.
Go to the top of the page
 
+Quote Post
UncleSkillet
post Jul 25 2009, 02:27 AM
Post #4


Learning Tone Seeker
*

Group: Members
Posts: 1.525
Joined: 21-January 08
From: Cincinnati, Ohio
Member No.: 3.915



QUOTE (Ctodd @ Jul 24 2009, 09:11 PM) *
hmmm I don't know what ASIO is, all I know is that it stands for audio sound input output, or something like that. But your comment made me go into my audio device settings and look for the word "ASIO"

and (I dont really know what these terms are)

my "audio system" was set to "waveout" but ASIO was an option, so i selected that, and different options came up,

I saw something about "thread priority" so I though it might be a good idea to set that to "highest" (later I changed it to "timing critical") and I also checked off a box that read "pre-zero output buffers ... (higher CPU usage)" so I checked that off too thinking it would help... and it did

no (noticeable) latency now!

but would you mind explaining any of the above?? laugh.gif

All I know how to do is tinker with things that look like they might help... I have no idea what I was doing laugh.gif

-Chris



My suggestion was to try and get you pointed in the right direction. What you clicked on after that and how it fixed your problem I really don't know. I'm glad things are working though. smile.gif

See you around


--------------------
"Think of a guitar solo as a paragraph. You need a clear beginning, a middle, and an end. Look at musical phrases like sentences, and make sure you break them up using punctuation—or space. You pause naturally when conversing, right? If you don't, you'll bore the listener. The same thing will happen with your audience if your solo is one dimensional. You'll wear them out and lose their attention." —Tom Principato
Go to the top of the page
 
+Quote Post
Muris Varajic
post Jul 25 2009, 05:10 PM
Post #5


Instructor
Group Icon

Group: GMC Instructor
Posts: 15.459
Joined: 22-June 07
From: Sarajevo,Bosnia
Member No.: 2.159



Buffer size is what determines latency, good work. biggrin.gif


--------------------
Youtube
MySpace
Website



Album "Let It Out" on
iTunes
and CD Baby

Check out my video lessons and instructor board!

The Pianist
tune is progress,check it out!

"ok.. it is great.. :P

have you myspace? Can i to personalize this for you guy?"
Go to the top of the page
 
+Quote Post
Vasilije Vukmiro...
post Jul 25 2009, 07:50 PM
Post #6


Jazz Instructor
Group Icon

Group: GMC Instructor
Posts: 2.691
Joined: 1-October 08
From: Belgrade
Member No.: 6.012



Try to fix buffer or to get some ASIO drivers, or better sound card!


--------------------
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 


RSS Lo-Fi Version Time is now: 17th January 2017 - 10:02 AM