Reply to this topicStart new topic
> Help With Midi Keyboard
superize
post Jul 4 2011, 04:46 PM
Post #1


Ultimate Tone Guru
Group Icon

Group: Student Instructor
Posts: 4.343
Joined: 26-July 07
From: Glommersträsk. Sweden
Member No.: 2.410



I got a Behringer UMX490 midi keyboard today and i am having some difficulties and was hoping to get some help.

I use Kore player from native instruments to get sound from the keyboard and i have maneged to get the sound through my computer but the problem i am having now is when i am using kore player and playing i cant get any sound from the computer or internet and its the other way around if am using the computer to listen to something.

Another problem i am having is that i cant get any sound from it when using it in my DAW(reaper).

I have looked in the manual but it doesent say anything and i am soon on about to explode in anger. I a mean i dont know what to do since i have never tried something like this.......

please help me


--------------------
My Gear

Ibanez RG
Jackson js30 warrior
jackson rr24
Line 6 Spider III amp
Line 6 pod xt live
Washburn acoustic

Youtube Account
My bands Myspace


Go to the top of the page
 
+Quote Post
Gabriel Leopardi
post Jul 4 2011, 05:12 PM
Post #2


Instructor
Group Icon

Group: GMC Instructor
Posts: 28.857
Joined: 3-March 07
From: Argentina
Member No.: 1.289



Hi man. I've never used the software that you are using. Regarding the first part of the question, maybe it's a limitation of your soundcard. I would try using another VSTi to know if the problem is your pc or if the problem is that the soft that you are using uses all the soundcard resources. I don't know Reaper but when I'm trying to do the same in Nuendo I have to open a section called "Instruments" where I choose the VSTi, then I assign that instrument in a Midi Channel and finally I set that channel in Recording mode. After doing those Steps the Midi Keyboard starts to sound.


--------------------
My lessons

Do you need a Guitar Plan?
Join Gab's Army

Check my band:Cirse
Check my soundcloud:Soundcloud

Please subscribe to my:Youtube Channel
Go to the top of the page
 
+Quote Post
Sollesnes
post Jul 5 2011, 12:53 AM
Post #3


Learning Tone Master
*

Group: Members
Posts: 1.940
Joined: 18-January 09
Member No.: 6.623



By your problem, it sounds like you are using Asio4all.
Asio4all does not share audio. You need to use a different driver.

Edit:
DAW is probably a different problem. Probably related to you not having it set up correctly in Reaper. But you're not really explaining much... Does Reaper recognize your keyboard? Does it react to you playing, but is simply not making sound to your speakers (in which case you need to check your outputs, or VSTs), or does Reaper simply not recognize your keyboard existing at all? if so, check your midi input like Gabriel said.

This post has been edited by Sollesnes: Jul 5 2011, 01:23 AM
Go to the top of the page
 
+Quote Post
superize
post Jul 5 2011, 09:53 AM
Post #4


Ultimate Tone Guru
Group Icon

Group: Student Instructor
Posts: 4.343
Joined: 26-July 07
From: Glommersträsk. Sweden
Member No.: 2.410



QUOTE (Sollesnes @ Jul 5 2011, 01:53 AM) *
By your problem, it sounds like you are using Asio4all.
Asio4all does not share audio. You need to use a different driver.

Edit:
DAW is probably a different problem. Probably related to you not having it set up correctly in Reaper. But you're not really explaining much... Does Reaper recognize your keyboard? Does it react to you playing, but is simply not making sound to your speakers (in which case you need to check your outputs, or VSTs), or does Reaper simply not recognize your keyboard existing at all? if so, check your midi input like Gabriel said.


Thanks for letting me know that it helped.

But i still cant get any sound when playing on the keyboard. I am now using kontakt 4 player and on that i can see a keyboard and when i play my midi keyboard i can see the keys in kontakt player moving but i am not getting any sound but when i click with my mouse on the keys i get the sound.

The driver i am using now is called WASAPi(shared mode)


--------------------
My Gear

Ibanez RG
Jackson js30 warrior
jackson rr24
Line 6 Spider III amp
Line 6 pod xt live
Washburn acoustic

Youtube Account
My bands Myspace


Go to the top of the page
 
+Quote Post
Sinisa Cekic
post Jul 5 2011, 09:08 PM
Post #5


Instructor
Group Icon

Group: GMC Instructor
Posts: 4.649
Joined: 15-October 08
From: Belgrade,Serbia
Member No.: 6.085



Try to change midi channel/number in Kontakt ! I once had a similar problem, and I think I solved it on that way !


--------------------
Go to the top of the page
 
+Quote Post
Sollesnes
post Jul 5 2011, 09:16 PM
Post #6


Learning Tone Master
*

Group: Members
Posts: 1.940
Joined: 18-January 09
Member No.: 6.623



If WASAPi works good, that's good, but I found in most cases ASIO4ALL beats the crap out of it. It's just the thing that ASIO4ALL doesn't share audio.

So the VST does recognize you playing the keyboard, but it doesn't play back any audio, but if you use your mouse on the virtual keyboard, it plays?
I would go through the VST midi settings, and of course the outputs of your DAW and see if everything looks good. Is the problem the same no matter what VSTs you run? Do you have properly installed and updated drivers for both the keyboard and your audio interface?

This post has been edited by Sollesnes: Jul 5 2011, 09:18 PM
Go to the top of the page
 
+Quote Post
superize
post Jul 6 2011, 01:28 PM
Post #7


Ultimate Tone Guru
Group Icon

Group: Student Instructor
Posts: 4.343
Joined: 26-July 07
From: Glommersträsk. Sweden
Member No.: 2.410



Update

For some reason when i turned on the keyboard today i get sound from the computer when playing but the only working driver i have i ASIO4ALL so i still cant share audio. There is another Audio driver on the Behringer webpage but for some reason i cant intall that on my computer. I have sent an email to the asking about this.

So now i got a keyboard i can play on wch is a start but i still havent figure out how to get it to work in reaper so i can record something.


--------------------
My Gear

Ibanez RG
Jackson js30 warrior
jackson rr24
Line 6 Spider III amp
Line 6 pod xt live
Washburn acoustic

Youtube Account
My bands Myspace


Go to the top of the page
 
+Quote Post
Ivan Milenkovic
post Jul 6 2011, 01:28 PM
Post #8


Instructor
Group Icon

Group: GMC Instructor
Posts: 25.396
Joined: 20-November 07
From: Belgrade, Serbia
Member No.: 3.341




You see, your keyboard is actually MIDI controller. What this means is that it sends MIDI signals to software that can read them, and play samples, according to what it receives. Kontakt Player has ability to read MIDI, so does any DAW software.

Now, I saw that UMX has USB Interface integrated in. It could be that you installed drivers for USB interface and now this device is acting as your sound card? Try to check that, go to windows control panel, under the sound driver playback try to find the device. It shouldn't be there, since you will not use this device as your audio interface.

Isac, I believe you have POD Studio right? Go in Kontakt player, settings, and try to choose your POD as your sound card/ASIO driver for playback. Then go to MIDI settings tab, and try to choose UMX MIDI as your MIDI Input Device. (output shouldn't be important).

Try this, and let us know if it worked!

This post has been edited by Ivan Milenkovic: Jul 6 2011, 01:29 PM


--------------------
- Ivan's Video Chat Lesson Notes HERE
- Check out my GMC Profile and Lessons
- (Please subscribe to my) YouTube Official Channel
- Let's be connected through ! Facebook! :)
Go to the top of the page
 
+Quote Post
Saoirse O'Shea
post Jul 6 2011, 01:46 PM
Post #9


Moderator - low level high stakes
Group Icon

Group: GMC Senior
Posts: 6.173
Joined: 27-June 07
From: Espania - Cadiz province
Member No.: 2.194



QUOTE (superize @ Jul 4 2011, 04:46 PM) *
...when i am using kore player and playing i cant get any sound from the computer or internet and its the other way around if am using the computer to listen to something.

...


ASIO 1 and 2 to my knowledge doesn't supprt multiclient. If your internet and pc sound are set to run on one sound card (ie on board) whilst you use an ASIO enabled audio device for the DAW and Kore you will only get sound from one. If this is the case you need to set the ASIO device as the sound device not just for Kore and your DAW but also for your pc to stream internet Youtube etc to.


--------------------
Get your music professionally mastered by anl AES registered Mastering Engineer. Contact me for Audio Mastering Services and Advice and visit our website www.miromastering.com

Be friends on facebook with us here.

We use professional, mastering grade hardware in our mastering studo. Our hardware includes:
Cranesong Avocet II Monitor Controller, Dangerous Music Liasion Insert Hardware Router, ATC SCM Pro Monitors, Lavry Black DA11, Prism Orpheus ADC/DAC, Gyratec Gyraf XIV Parallel Passive Mastering EQ, Great River MAQ 2NV Mastering EQ, Kush Clariphonic Parallel EQ Shelf, Maselec MLA-2 Mastering Compressor, API 2500 Mastering Compressor, Eventide Eclipse Reverb/Echo.
Go to the top of the page
 
+Quote Post
superize
post Jul 6 2011, 02:23 PM
Post #10


Ultimate Tone Guru
Group Icon

Group: Student Instructor
Posts: 4.343
Joined: 26-July 07
From: Glommersträsk. Sweden
Member No.: 2.410



Ok good news i got it working in reaper so that i can listen and record. I am using my toneport GX as audio device and that worked in reaper but its still the same when it comes to hearing both from kontak and internet

Updadate:

Now i got it working everywhere. Using my toneport as audio device worked for now thanks alot Ivan for the tips

This post has been edited by superize: Jul 6 2011, 02:27 PM


--------------------
My Gear

Ibanez RG
Jackson js30 warrior
jackson rr24
Line 6 Spider III amp
Line 6 pod xt live
Washburn acoustic

Youtube Account
My bands Myspace


Go to the top of the page
 
+Quote Post
Sollesnes
post Jul 6 2011, 02:29 PM
Post #11


Learning Tone Master
*

Group: Members
Posts: 1.940
Joined: 18-January 09
Member No.: 6.623



Congratulations. smile.gif

This post has been edited by Sollesnes: Jul 6 2011, 02:29 PM
Go to the top of the page
 
+Quote Post
superize
post Jul 6 2011, 02:42 PM
Post #12


Ultimate Tone Guru
Group Icon

Group: Student Instructor
Posts: 4.343
Joined: 26-July 07
From: Glommersträsk. Sweden
Member No.: 2.410



Thanks for all your help guys biggrin.gif biggrin.gif biggrin.gif biggrin.gif biggrin.gif biggrin.gif biggrin.gif


--------------------
My Gear

Ibanez RG
Jackson js30 warrior
jackson rr24
Line 6 Spider III amp
Line 6 pod xt live
Washburn acoustic

Youtube Account
My bands Myspace


Go to the top of the page
 
+Quote Post
Ivan Milenkovic
post Jul 6 2011, 08:35 PM
Post #13


Instructor
Group Icon

Group: GMC Instructor
Posts: 25.396
Joined: 20-November 07
From: Belgrade, Serbia
Member No.: 3.341



Glad to help man! smile.gif


--------------------
- Ivan's Video Chat Lesson Notes HERE
- Check out my GMC Profile and Lessons
- (Please subscribe to my) YouTube Official Channel
- Let's be connected through ! Facebook! :)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 


RSS Lo-Fi Version Time is now: 29th May 2017 - 01:16 AM