Reply to this topicStart new topic
> Voodoo Lab Power Plus 2, purchased one hooked it the POP, puff of smoke
dcz702
post May 5 2014, 08:30 AM
Post #1


Learning Tone Seeker
*

Group: Members
Posts: 613
Joined: 5-March 13
From: Las Vegas
Member No.: 17.838



so i bought a voodoo lab power plus 2 and when i got it all hooked up tidied up my board with zip ties all orgazized and set, plugged it in light went on the supply unit, then proceeded to switch on pedals individually, my mxr delay's light was very faint like it had a dying battery flipped over my board to check the connections, then i hear a faint pop, followed by a puff of tiny smoke, then the unit was dead!!!! mellow.gif dry.gif dry.gif
all my pedals are 9 volt pedals and all setting on the power supply were set to normal. i plugged it into a power strip that also had my amp plugged into. anyone know why this could happen?? something i did wrong? or just a faulty unit?
taking it back to exchange for the same unit tomorrow dry.gif

This post has been edited by dcz702: May 5 2014, 08:31 AM
Go to the top of the page
 
+Quote Post
klasaine
post May 5 2014, 04:04 PM
Post #2


GMC:er
*

Group: Members
Posts: 2.743
Joined: 30-December 12
From: Los Angeles, CA
Member No.: 17.304



Voodoo Labs unit dead or the MXR (carbon copy) dead?


--------------------
Go to the top of the page
 
+Quote Post
SeeJay
post May 5 2014, 05:52 PM
Post #3


GMC:er
*

Group: Members
Posts: 373
Joined: 1-May 14
From: Orlando, FL USA
Member No.: 19.758



All the other pedals seem to play fine, but the MXR's LED seemed faint?

hmmm. . .

Probably a faulty unit, but what pedals did you hook up to it?

Make sure you check them all before you tie it down next time. I put together a pedal board, tied everything down and then had to tear it all completely apart to find a bad patch cable I had made. what a waste of a day. happy.gif


--------------------
Rock and Roll Lover. Vintage Ampeg collector. Soon to be new father.
Go to the top of the page
 
+Quote Post
Todd Simpson
post May 5 2014, 06:07 PM
Post #4


GMC:er
Group Icon

Group: GMC Instructor
Posts: 14.124
Joined: 23-December 09
From: Atlanta, Georgia, USA
Member No.: 8.794



EEGAD!!!!! Sounds like what happens when you plug the wrong power in the wrong slot. It could be a faulty unit though, I 'd check all your pedals with batts to see if anything got fried. Was the voodoo used by chance?

The only unit I've ever owned is the rebranded joyo and it was only $35 but it's been solid as a rock.

Attached Image

QUOTE (dcz702 @ May 5 2014, 03:30 AM) *
so i bought a voodoo lab power plus 2 and when i got it all hooked up tidied up my board with zip ties all orgazized and set, plugged it in light went on the supply unit, then proceeded to switch on pedals individually, my mxr delay's light was very faint like it had a dying battery flipped over my board to check the connections, then i hear a faint pop, followed by a puff of tiny smoke, then the unit was dead!!!! mellow.gif dry.gif dry.gif
all my pedals are 9 volt pedals and all setting on the power supply were set to normal. i plugged it into a power strip that also had my amp plugged into. anyone know why this could happen?? something i did wrong? or just a faulty unit?
taking it back to exchange for the same unit tomorrow dry.gif



--------------------
Go to the top of the page
 
+Quote Post
SeeJay
post May 5 2014, 07:06 PM
Post #5


GMC:er
*

Group: Members
Posts: 373
Joined: 1-May 14
From: Orlando, FL USA
Member No.: 19.758



I get skeptical when people mention inexpensive power supplies. It just seems like it needs to be a piece that some quality components are put into. There's a lot of great options out there now.

And I've never heard any complaints about the JOYO one you mentioned and it probably works great,

but,

Some things to me are worth a little bit of an investment to not have to worry about.

But that pedal power blew for this guy, so who knows. wink.gif wink.gif wink.gif

Anyone use the CIOKS stuff? Seems to be the new hottness.

QUOTE (Todd Simpson @ May 5 2014, 05:07 PM) *
EEGAD!!!!! Sounds like what happens when you plug the wrong power in the wrong slot. It could be a faulty unit though, I 'd check all your pedals with batts to see if anything got fried. Was the voodoo used by chance?

The only unit I've ever owned is the rebranded joyo and it was only $35 but it's been solid as a rock.

Attached Image



--------------------
Rock and Roll Lover. Vintage Ampeg collector. Soon to be new father.
Go to the top of the page
 
+Quote Post
dcz702
post May 5 2014, 08:33 PM
Post #6


Learning Tone Seeker
*

Group: Members
Posts: 613
Joined: 5-March 13
From: Las Vegas
Member No.: 17.838



QUOTE (klasaine @ May 5 2014, 03:04 PM) *
Voodoo Labs unit dead or the MXR (carbon copy) dead?

Voodoo lab died. On my way out to exchange it.

QUOTE (Todd Simpson @ May 5 2014, 05:07 PM) *
EEGAD!!!!! Sounds like what happens when you plug the wrong power in the wrong slot. It could be a faulty unit though, I 'd check all your pedals with batts to see if anything got fried. Was the voodoo used by chance?

The only unit I've ever owned is the rebranded joyo and it was only $35 but it's been solid as a rock.

Attached Image

I'm pretty sure I followed directions right. I plugged everything in before powering on. And all my pedals are low draw from according to their manuals. The box the voodoo came in was not wrapped in plastic and not sealed so maybe it was used. Don't know. Hopefully the new one I get works or I'm not gonna be happy.
Go to the top of the page
 
+Quote Post
Bogdan Radovic
post May 5 2014, 08:41 PM
Post #7


Bass & Beginner Instructor
Group Icon

Group: GMC Instructor
Posts: 15.612
Joined: 30-November 07
From: Belgrade, Serbia
Member No.: 3.410



QUOTE (dcz702 @ May 5 2014, 09:33 PM) *
The box the voodoo came in was not wrapped in plastic and not sealed so maybe it was used. Don't know. Hopefully the new one I get works or I'm not gonna be happy.


I hate it when they sell "used" stuff as new in the stores sad.gif
If someone has taken it home, it can't be really considered as new and there might be a reason the person returned it.

Also do the store owners really check if the returned unit works? In most cases no.

Hope you get a new one which works nicely soon smile.gif


--------------------
For GMC support please email support (at) guitarmasterclass.net
Check out my lessons and my instructor board.
Check out my beginner guitar lessons course! ; Take a bass course now!
My solo and band songs : Keep Going On, Night Vibe, Kad Te Vidim, Susret, Plava Silueta
Go to the top of the page
 
+Quote Post
Todd Simpson
post May 5 2014, 11:13 PM
Post #8


GMC:er
Group Icon

Group: GMC Instructor
Posts: 14.124
Joined: 23-December 09
From: Atlanta, Georgia, USA
Member No.: 8.794



Case in point smile.gif The Voodoo Pedal Power (way more pricey than the joyo) BLEW UP!!! (could just be a faulty unit, still) Meanwhile the cheapy Joyo, never a moments trouble. Just goes to again show..

"Higher Price Doesn't Always Mean Better Quality"


To each his own. Some folks like putting money in to power supplies as KLAISAINE mentioned. Makes em feel better smile.gif

So far, the joyo is the only one I"ve worked with. I did wads of research before buying and it was the hands down winner price/performance.



QUOTE (SeeJay @ May 5 2014, 02:06 PM) *
I get skeptical when people mention inexpensive power supplies. It just seems like it needs to be a piece that some quality components are put into. There's a lot of great options out there now.

And I've never heard any complaints about the JOYO one you mentioned and it probably works great,

but,

Some things to me are worth a little bit of an investment to not have to worry about.

But that pedal power blew for this guy, so who knows. wink.gif wink.gif wink.gif

Anyone use the CIOKS stuff? Seems to be the new hottness.


This post has been edited by Todd Simpson: May 5 2014, 11:15 PM


--------------------
Go to the top of the page
 
+Quote Post
klasaine
post May 6 2014, 12:22 AM
Post #9


GMC:er
*

Group: Members
Posts: 2.743
Joined: 30-December 12
From: Los Angeles, CA
Member No.: 17.304



Sometimes stuff doesn't work.
It does suck when it's a pricey piece of gear. If the VL was sold as new and it wasn't then obviously the previous owner either got a bad unit or broke that one.

My only reason for recommending it is that I've had 2 VLPPs since the late 90s, both used HEAVILY (by me) since then and I've never had an issue. Same with the t-rex FTs. *I've never had a failure with any power supply, of any price point, ever - so ... that one in a million thing.

This post has been edited by klasaine: May 6 2014, 12:24 AM


--------------------
Go to the top of the page
 
+Quote Post
Todd Simpson
post May 6 2014, 02:09 AM
Post #10


GMC:er
Group Icon

Group: GMC Instructor
Posts: 14.124
Joined: 23-December 09
From: Atlanta, Georgia, USA
Member No.: 8.794



2 Years with zero issues is a very good thing. I've only had mine a few weeks at this point so it's still young. It may yet crap out, but so far so good!!

I have very little experience with power supplies as this is my first one to be honest. I did to tons of research and the voodoo kept coming up. It was actually down to the voodoo and joyo/cadine in the end. Joyo won out just on price.

I almost got the Voodoo foot controller for my 11 Rack. It kept coming up as being a better value than the pricier fractal audio floor board. Both of them lost out to the Behringer foot controller again on price. Also, the behringer has two pedals for volume/wah where as the others require additional add ons for volume/wah.

QUOTE (klasaine @ May 5 2014, 07:22 PM) *
Sometimes stuff doesn't work.
It does suck when it's a pricey piece of gear. If the VL was sold as new and it wasn't then obviously the previous owner either got a bad unit or broke that one.

My only reason for recommending it is that I've had 2 VLPPs since the late 90s, both used HEAVILY (by me) since then and I've never had an issue. Same with the t-rex FTs. *I've never had a failure with any power supply, of any price point, ever - so ... that one in a million thing.


--------------------
Go to the top of the page
 
+Quote Post
dcz702
post May 6 2014, 02:41 AM
Post #11


Learning Tone Seeker
*

Group: Members
Posts: 613
Joined: 5-March 13
From: Las Vegas
Member No.: 17.838



QUOTE (Bogdan Radovic @ May 5 2014, 07:41 PM) *
I hate it when they sell "used" stuff as new in the stores sad.gif
If someone has taken it home, it can't be really considered as new and there might be a reason the person returned it.

Also do the store owners really check if the returned unit works? In most cases no.

Hope you get a new one which works nicely soon smile.gif

oh boy me to bogdan! so i returned the first dead one and exchanged it for another, when i got home with the second one and unpacked it, 2 cable connectors were missing! boy was i getting bent at that point dry.gif ive gone to guitar center 4 times in 2 days and i live a half hour drive from there!
so i returned the second unit got my money back and went to sam ash and purchased one that the packaging of the inside goodies were sealed, i guess voodoo lab doesnt seal the boxes themselves, said the guys helping me.

QUOTE (klasaine @ May 5 2014, 11:22 PM) *
My only reason for recommending it is that I've had 2 VLPPs since the late 90s, both used HEAVILY (by me) since then and I've never had an issue.

so i need some help klasaine, the salesmen at guitar center told me that the reason my first unit blew was because of the current draw of my pedals and i hooked them up wrong, the voodoo lab manual states that output 1-4 is 100ma, 5-6 is 250 ma, and 7-8 is 100ma. Is that for each out? output 1 delivers 100ma by itself? and output 5 delivers 250ma, or do i need to make sure that when using all outputs 1-4 that all four pedals do not exceed 100ma combined? i was told by the guy at guitar center that if i have for pedal just and say each have a 30ma power draw that outputs 1-4 100ma would be exceeded my 20ma cauing damage to the unitwich is what i did i guess?
but the voodlab website states each output is 100 and 5-6 each out is 250, heres a screen shot of voolab website

to be safe i have gathered all my info on pedals and to be safe im going to go off of what guitar center told me for now,
this is my pedals MA draw
wah 6.3
delay 26
compressor 5
phaser 5
chorus 30
reverb 100
decimator 100
tu-3 30 (in lowest brighness mode)
so ill put wah, compressor, phaser, chorus in 1-4
reverb and decimator in 5-6
tuner, delay in 7-8 assuming that the guy at guitar center is right.
Attached image(s)
Attached Image Attached Image
 
Go to the top of the page
 
+Quote Post
klasaine
post May 6 2014, 04:25 AM
Post #12


GMC:er
*

Group: Members
Posts: 2.743
Joined: 30-December 12
From: Los Angeles, CA
Member No.: 17.304



1) I would never trust anything a guy at GC says (I hate that place). Seriously, very few ever have any clue what they're talking about at all especially when it comes to specs on electronics.

2) None of your pedals are remotely out of the ordinary.
I am curious what reverb pedal you're using that draws 100 ma?

3) Each out on the PP2 is at least 100 ma as the VL literature says.

4) Without seeing all your gear and your set-up I don't want to say anything else. I doubt it but 'maybe' one of your pedals is acting weird(?).

As I say I've had two PPs since the 90s and I never even think about what I plug into them other than if a pedal needs ACA power (which is not most of them).

This post has been edited by klasaine: May 6 2014, 04:27 AM


--------------------
Go to the top of the page
 
+Quote Post
dcz702
post May 6 2014, 05:14 AM
Post #13


Learning Tone Seeker
*

Group: Members
Posts: 613
Joined: 5-March 13
From: Las Vegas
Member No.: 17.838



QUOTE (klasaine @ May 6 2014, 03:25 AM) *
1) I would never trust anything a guy at GC says (I hate that place). Seriously, very few ever have any clue what they're talking about at all especially when it comes to specs on electronics.

2) None of your pedals are remotely out of the ordinary.
I am curious what reverb pedal you're using that draws 100 ma?

3) Each out on the PP2 is at least 100 ma as the VL literature says.

4) Without seeing all your gear and your set-up I don't want to say anything else. I doubt it but 'maybe' one of your pedals is acting weird(?).

As I say I've had two PPs since the 90s and I never even think about what I plug into them other than if a pedal needs ACA power (which is not most of them).

Yea I don't really trust GC either. After returning twice they offered a third exchange that appeared to be unopened but I chose to get money bank instead and took it to Sam ash. I like to shop at Sam ash, guitar center is just closer to me.
The power requirement from the literature and what you say is what I thought all along. Then I got a bit confused after talking to GC guy. That's when I decided to go elsewhere.
I'm using a tc electronic arena reverb with tone print, it draws more power than usual because of the tone print feature, I'm guessing.
Got my new voodoo lab hooked up and working. Board is nice and quite and pedals to me sound more vibrant, or maybe that my head playing tricks on me but everything sounds better. smile.gif now that I've got it all sorted out its time to get to playing, spent to much time sorting shit out. laugh.gif
Go to the top of the page
 
+Quote Post
klasaine
post May 6 2014, 06:58 AM
Post #14


GMC:er
*

Group: Members
Posts: 2.743
Joined: 30-December 12
From: Los Angeles, CA
Member No.: 17.304



Glad it's working out!
Gear problems are a drag especially when you think you're doing everything right and then you get contradictory info and/or a faulty piece of gear. Very frustrating.

I figured the verb was either a Line 6 or a TC. Those pull about 100 ma.
I use a TC 'flashback' delay on a board and never had an issue. I'm sure it too draws a max of 100 ma.


--------------------
Go to the top of the page
 
+Quote Post
SeeJay
post May 7 2014, 03:50 PM
Post #15


GMC:er
*

Group: Members
Posts: 373
Joined: 1-May 14
From: Orlando, FL USA
Member No.: 19.758



Glad it's working out. Time to post a pic!


--------------------
Rock and Roll Lover. Vintage Ampeg collector. Soon to be new father.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 


RSS Lo-Fi Version Time is now: 25th March 2017 - 08:44 PM